Qemu : boot error

#1

hello,
I beginning just to use Clip Os, I must to install on Ubuntu 18.04 LTS.
Install is find, but when i try to build it, they create some unbootable qcow2.

The mistake append during Clip Os run in qemu:

[ OK ]Stopped dracut initqueue hook.
[ 4.310232] echo[460]:
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
Something unexpected happened during boot up.
Please contact your local system administrator.
You may now turn this computer off.
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
[ OK ]Started Warning displayed when the boot failed for an any reason
[ OK ] Reached target Boot failed target.

I have searched for a solution but i do not progress.

can you help me ?

thanks

Jean

#2

If you reach this warning, this probably means that you have successfully built a production image and that you do not have TPM emulation (swtpm) installed. Please see the last two steps from the Building page for instructions on how to install swtpm.

To be able to log into the system you will also have to build a development enabled image. If you do not wish to install the TPM emulator, the development image will also let you boot without it, using core_state_key as LUKS passphrase.

#3

Hello! I had the same error, and was able to move past it after installing swtpm and libtpms, but now the error I receive is different. Before getting here, I encountered some file permission errors with swtpm, but was able to work past that. I don’t know how to get around this error, though.

(toolkit) archlinux% sujust qemu                  
just products/clipos/qemu
just qemu/bundle
just ../sdk_debian/all
cosmk bundle "clipos/qemu"
 [-] 'clipos/sdk_debian' bundles recipe 'clipos/qemu', runs:
       {{repo}}/products/{{product}}/{{recipe}}/bundle.sh
(SDK) [!] Re-using cached empty QEMU disk image!
'/mnt/cache/clipos/5.0.0-alpha.1/qemu/bundle/empty.qcow2' -> '/mnt/out/clipos/5.0.0-alpha.1/qemu/bundle/main.qcow2'
(SDK) [*] /mnt/out/clipos/5.0.0-alpha.1/qemu/bundle/main.qcow2: Adding /mnt/out/clipos/5.0.0-alpha.1/efiboot/bundle/efipartition.tar in EFI system partition...
(SDK) [+] /mnt/out/clipos/5.0.0-alpha.1/qemu/bundle/main.qcow2: Adding /mnt/out/clipos/5.0.0-alpha.1/efiboot/bundle/efipartition.tar in EFI system partition: OK
(SDK) [*] /mnt/out/clipos/5.0.0-alpha.1/qemu/bundle/main.qcow2: Adding /mnt/out/clipos/5.0.0-alpha.1/core/bundle/core.squashfs.verity.bundled in core_5.0.0-alpha.1...
(SDK) [+] /mnt/out/clipos/5.0.0-alpha.1/qemu/bundle/main.qcow2: Adding /mnt/out/clipos/5.0.0-alpha.1/core/bundle/core.squashfs.verity.bundled in core_5.0.0-alpha.1: OK
(SDK) [*] Setting up modules and firmwares
(SDK) [*] Creating QEMU initial core state tarball...
(SDK) [*] /mnt/out/clipos/5.0.0-alpha.1/qemu/bundle/main.qcow2: Adding /mnt/out/clipos/5.0.0-alpha.1/qemu/bundle/qemu-core-state.tar in core_state...
(SDK) [+] /mnt/out/clipos/5.0.0-alpha.1/qemu/bundle/main.qcow2: Adding /mnt/out/clipos/5.0.0-alpha.1/qemu/bundle/qemu-core-state.tar in core_state: OK
just qemu/run
cosmk spawn "clipos/qemu"
libvirt: Cgroup error : Failed to create v1 controller cpu for group: No such file or directory
 [X] Uncaught unknown exception libvirtError:
     Failed to create v1 controller cpu for group: No such file or directory
error: Recipe `run` failed on line 26 with exit code 1
error: Recipe `qemu` failed on line 36 with exit code 1
error: Recipe `qemu` failed on line 24 with exit code 1

Is this an environment variable? Do I need to update a config file somewhere?

Thanks for the assistance!

#4

Hello Benson,

This is a known bug with libvirt that we are still investigating, but the workaround is to disable libvirt’s use of those cgroups. To achieve this, you can remove the cpu* cgroups from the cgroup_controllers list in your libvirt QEMU driver configuration file (e.g. /etc/libvirt/qemu.conf). For instance I have the following in my own configuration file:

#cgroup_controllers = [ "cpu", "devices", "memory", "blkio", "cpuset", "cpuacct" ]
cgroup_controllers = [ "devices", "memory", "blkio" ]

By the way, I’d be happy if you could tell us a bit more about the permission errors you had to get around with swtpm. Thanks!

No, it’s just a passphrase you need to manually type in.