Running with QEMU on macOS or without KVM support

Hi everybody,
I’m trying to follow the “Quick try guide” about CLIP OS 5, however I get the same error everytime, whatever the OS I use : Multipass Ubuntu 16.04 and 18.04LTS, MacOs Catalina.
So I follow the steps, no problems (except with tar : “zst is not a tar [whatever]” for this command :
tar xf qemu.tar.zst && cd clipos_*_qemu, so I use zstd -d qemu.tar.zst then tar xf qemu.tar && cd clipos_*_qemu), then when I execute this :
./qemu.sh
I get the error : qemu-system-x86_64: -overcommit: invalid option

How can I fix that ?

Thanks for helping !

Gryfbane

Can you remove the line -overcommit mem-lock=off \ from the qemu.sh script and try again?

I tried, but I get numerous errors then… I’m running under Catalina, I’m pretty sure this is actually the whole problem ; the first one is that it seems that there’s no -sandbox options for qemu with macos, so it’s impossible to run the different “cages” of the architecture.
If I use the Multipass (which uses qemu) Ubuntu 16.04, I’m not sure to launch another VM for clip OS “inside” my Ubuntu qemu VM…
I’m currently trying to set a proper Ubuntu installation in my Macbook (post 2018), but the used Linux kernel (5.0.0) for Ubuntu 19.10 seems to have issues with the Apple’s NVMe…

Thanks for your help !

This QEMU option is unrelated to CLIP OS cages and can be safely disabled for testing.

You can try running without KVM acceleration (remove accel=kvm from the script) or you need to enabled nested virtualization in you BIOS/Firmware to be able to launch virtual machines inside virtual machines.

I’m sorry but we do not support macOS as a development platform (I don’t have any available).

Ok, I’m gonna try this, thank you !

Can you help me please ?
After remove the line -overcommit mem-lock=off \ and accel=kvm from the qemu.sh script and try again, I’ve got the message:

Warning /dev/mainvg does not exist
Warning /dev/mapper/verity_core_5.0.0-beta.3 does not exist

Generating "/run/initramfs/rdsosreport.txt"

Entering emergency mode. Exit the shell to continue.
Type "journalctl" to view system logs.

JOURNALCTL=

kernel: CPU: vendor_id 'AuthenticAMD' unknown, using generic init
kernel: Your system may be unstable
kernel: mtrr: your cpus has inconsistent fixed MTRR setting
kernel: mtrr: your cpus has inconsistent variable MTRR setting
kernel: mtrr: your cpus has inconsistent MTRRdefType setting

kernel: mce: Unable to ini MCE device (rc: -5)

systemd [1]: failed to lookup module alias autofs4 : Function not implemented

systemd [1]: dev-mapper-verity_core_5.0.0\x2dbeta.3.device: Job dev-mapper-verity_core_5.0.0\x2dbeta.3.device/start timeout
systemd [1]: Time out waiting for device /dev/mapper/verity_core_5.0.0-beta.3.
systemd [1]: Dependency failed for Initrd Root Device
systemd [1]: Dependency failed for /sysroot
systemd [1]: Dependency failed for Initrd Root File System
systemd [1]: Dependency failed for Reload Configuration from the Real Root

@odefoulounoux Are you running on Linux or macOS? Can you give us the output of:

$ ls /dev
$ ls /dev/mapper

Hello,

I’m running on Linux.

ls /dev =
adsp, audio,, block, char, console, cpu_dma_latency, disk, dsp, fb0, fd, full, hpet, hwrng, input,kmsg,log, mapper,memory_bandwidth,mixer, network_latency, network_throughput, null, ptms, pts, random, sequencer, sequencer2, shm, snd,stderr, stdin,stdout, tty, tty0, tty1,..., tty63, urandom,vcs, vcs1, vcsa, vcsa1, vcsu, vcsu1, vda, vda1, vda2, zero.

ls dev/mapper =
control

thx

It looks like the drives are properly detected but not the LVM volumes. This is unexpected.
Can you tell us which Linux distribution you are using and which version for the kernel, QEMU, etc?

Linux Mint 19.3
uname -a = Linux GL753VD 5.0.0-37-generic #40~18.04.1-Ubuntu SMP Thu Nov 14 12:06:39 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

qemu (1:2.11+dfsg-1ubuntu7.21).

I have the same issue in a fresh LInux Mint 19.3 virtual machine if I remove overcommit & accell=kvm. However, the machine starts properly with KVM enabled, so you should try that if possible. I will try to find the issue with the no KVM setup.

You can work around this issue by entering the following commands at the given prompt:

$ loadkeys fr                            # Optional, for AZERTY layout
$ lvm vgchange -a y
$ systemctl start initrd.target
...

thanks, it’s work. I try with kvm later because of it doesn’t work at first…

hello,
The machine starts properly with KVM enabled but I always have the lvm volumes which are not detected.
systemd-udevd[299]: /lib/udev/rules.d/11-dm-lvm.rules:40 Invalid value for OPTIONS key, ignoring: ‘event_timeout=180’
systemd-udevd[299]: /lib/udev/rules.d/11-dm-lvm.rules:40 The line takes no effect, ignoring.

FWIW I’ve been observing these same logs on my machine for some time now and LVM volumes are still correctly detected, so I’d say it’s not related to your issue.